Xcode

在Xcode 5.0.1中,以iOS6測試

有了iOS7,必需將Xcode升級到Xcode 5,但是iOS simulator只有iOS7。若要測iOS6,該如何做?

iOS Simulator failed to install the application

當發生iOS Simulator failed to install the application時

iOS Simulator/Reset Content and Settings

 

http://stackoverflow.com/questions/12932750/ios-simulator-failed-to-install-the-application

Thread1:Program received signal:"SIGABRT"

Thread1:Program received signal:"SIGABRT"

這是由Xcode4.6.2產生的project,修改Deployment Target 5.0後,Product/Run在iPhone5.0 simulator或iPad5.0simulator時,所產生的錯誤。若Product/Run在iPhone5.0 simulator或iPad5.0simulator時,不會有問題。

Mac快速鍵

 以下是Mac經常可用到的快速鍵 :

Download wwdr in Xcode 4.6.2

 在Xcode4.6.2 Download wwdr的方法:

過去在developer網頁中download wwdr很直覺,現在(2013-07-19)找不到了,所以從Xcode download

  1. 打開Xcode4.6.2
  2. Editor/Refresh from Developer Portal,做了這一步,所有的provision profile,Certificate(含wwdr)都會重新download至MAC

 download wwdr

 

The executable 'the.app' is not a Position Independent Executable. Please ensure that your build settings are configure

昨天2013-07-17上傳後收到蘋果的一封信,重點如下: 

The executable 'ott.app' is not a Position Independent Executable. Please ensure that your build settings are configured to create PIE executables.

在網上找了一下,有些解法,但不完全,試了多次,最終把問題解了,解法如下:

首先,我用Xcode4.6.2。

(A)先講答案:

檢查memory leak

 在Xcode 4.6.2,

Product/profile

iOS/Memory/Leaks

點Leak

即可

訂閱文章